Symbolbild Installation con4gis

Contao 4 und die benötigten Bundles installieren.

Kurzbeschreibung

Contao installieren

Die offizielle Dokumentation findest Du hier: https://contao.org/de/download.html

Installation Contao 4

Die Installation von Contao 4 ist inzwischen auch sehr einfach geworden. Wichtig ist, dass Dein Webhoster Composer unterstützt und eine aktuelle PHP Version installiert ist. In Deinem Hosting-Paket muss der "Document Root" auf das Unterverzeichnis "web" Deines Webspaces verweisen.

Im Downloadbereich auf der contao.org Seite kannst Du Dir den Contao-Manager herunterladen und die Phar-Datei in das web-Verzeichnis schieben. Danach ergänzst Du die *.phar um ein .php. Also im Normalfall contao-manager.phar.php und genau diese Datei rufst Du dann im Browser auf. Alle weiteren Schritte sind dann komfortable über die Oberfläche möglich. Über den Manager kannst Du dann auch direkt die gewünschten con4gis Bausteine installieren.

Wer die Wahl hat, sollte auf eine aktuelle PHP-Version setzen (>= 7.2). Außerdem ist es ratsam wenn möglich die aktuelle LTS-Version (Long Term Support) einzusetzen.

Installation Contao 3

Contao 3 kannst Du, wie auf contao.org beschrieben, schnell und einfach installieren. Für die con4gis Module solltest Du die Contao Erweiterungsverwaltung benutzen und Dir darüber die Bausteine die Du brauchst installieren. Wenn Du eine einfache Kartenanwendung aufbauen möchtest, musst Du lediglich con4gis_maps3 installieren. Die von Maps3 benötigten Pakete, werden dann automatisch mitinstalliert.

Wichtig: Die con4gis Extensions für Contao 3 entsprechen nicht dem neuesten Entwicklungsstand. Die con4gis Extensions werden nicht mehr weiterentwickelt. Du solltest, wenn möglich, zu Contao >= 4.4 wechseln, denn auch die letzte Contao 3 Version (3.5) erhält ab Mai 2019 keine sicherheitsrelevanten Updates mehr und sollte spätestens dann nicht mehr verwendet werden (Contao Releaseplan).

Mehr auf: https://contao.org/de/

con4gis installieren

Mindestanforderungen

Contao LTS 4.4.x - Für Contao 3 nutze die con4igs_maps3 Extension.

Hinweis zur Installation der con4gis-Bausteine

Wenn Du „ con4gis-Bausteine“ nicht über den Contao Manager, Composer und das Contao 3 ER (Extension Repository) installierst, beachte bitte, dass Du auch die aktuelle Version von „con4gis-Core“ mitinstallieren musst. Der Core-Baustein wird immer benötigt.

Beispielansicht für Infos & Hilfe im Con4gis-Core
Zum Vergrößern bitte Bild anklicken

con4gis-Core

Das Modul con4gis-Core enthält alle Bibliotheken und Hilfsfunktionen der Module des con4gis-Baukastens. Es ist generell bei jeder Installation einer con4gis-Erweiterung automatisch integriert und erscheint prüfbar im Backend-Menü im Abschnitt "Con4gis X.X - Grundfunktionen" im Menüpunkt Info & Hilfe über dem Menübereich der installierten con4gis Bausteine.

Zusätzlich sind hier hilfreiche Links und Tools aufgeführt. Diese bieten Dir weitere Möglichkeiten, die verschiedenen Systeme ohne langes Suchen zum Ergänzen Deiner eigenen Projekte optimal einzusetzen.

FAQs zur Installation